HackerRank Week of Code 23——Enclosure(等周定理+余弦定理)_2016 e - enclosure csdn-程序员宅基地

技术标签: 计算方法  常见几何问题  

Vigo the Carpathian is an evil feudal lord. He wants to seize land from his serfs by enclosing it with a polygonal fence where each respective side has a strictly specified length. Can you help him maximize the fenced area?

Given a sequence of n lengths (i.e., L1,L2,,Ln ) where each is the length of the kth side, find a sequence of points (where pk=(xk,yk) ) such that dist (pk,pk+1)=Lk and dist (p1,pn)=Ln where dist (a,b)is the Euclidean distance between points a and b. Note that the first point, p1 , must be (0,0)and the second point, p2 , must be (0,L1) . These points must correspond to the ordered clockwise vertices of the simple polygon having the maximum possible area for the given side lengths. Then print the points according to the instructions in the Output Format section below.

Input Format

The first line contains a single integer,n , denoting the number of sides in the polygon.
The second line contains n space-separated positive integers describing each respective Lk . It is guaranteed that you can form an -edge polygon with the given sequence of lengths.

Constraints

  • 3n104
  • 1LK104

Output Format

For each of the n points (i.e., vertices in the polygon), print three lines in the following format:

The first line must contain a single floating-point number denoting the point's x-coordinate.
The second line must contain a single floating-point number denoting the point's y-coordinate.
The third line must be empty and serves as a visual spacer between the last point's -coordinate and the next point's x-coordinate.

You must print a total of 3*n lines of output. Your output is considered to be correct if the absolute difference from the correct answer for each coordinate is not greater than 101 . It is guaranteed that the exact correct answer is unique.

Sample Input 0

4
1 2 1 2

Sample Output 0

0.000000
0.000000

0.000000
1.000000

2.000000
1.000000

2.000000
0.000000

Explanation 0

The enclosure is a quadrilateral (specifically, a parallellogram). The area enclosed by the fence is maximal when it’s a rectangle.

Sample Input 1

3
1 1 1

Sample Output 1

0.000000
0.000000

0.000000
1.000000

0.866025
0.500000

Explanation 1

The only possible polygon is an equilateral triangle.

按照顺时针的顺序给你n边形的边长,输出n边形的n个顶点的坐标使得多边形的面积最大。

当周长已知的时候,多边形的面积越接近圆面积越大,所以最后的多边形一定有一个外接圆,多边形的边长为圆上的弦长。所以我们根据这个条件可以求出对应的圆心角。所以我们可以根据圆心角的大小判断所选的直径是不是合适。二分出圆的直径,然后向量旋转求坐标。

#include <bits/stdc++.h>
using namespace std;
const int INF = 0x3f3f3f3f;
const double eps = 1e-9;
const double pi = acos(-1.0);
const int maxn = 1e4+100;
double a[maxn];
struct node{
    double x,y;
    node(){}
    node(double _x,double _y):x(_x),y(_y){}
    node operator + (const node &b)const  {
        return node(x+b.x,y+b.y);
    }
    node operator * (const double &b) const{ //向量旋转
        return node(x*cos(b)-y*sin(b),x*sin(b)+y*cos(b));
    }
}ans[maxn];
int main(){
    int n;
    scanf("%d",&n);
    double r = 0;
    for(int i = 0;i<n;i++) {
        scanf("%lf",&a[i]);
        r+=a[i];
    }
    int mx = 0;
    for(int i = 1;i<n;i++) if(a[i]>a[mx]) mx = i;
    double l = a[mx]/2;
    double phi = 0;
    for(int i = 0;i<n;i++) {
            if(i != mx)phi += acos(1-a[i]*a[i]/(2*l*l));
    }
    bool flag = phi<pi;
    r *=2;
    while(r-l>eps) {
   //二分半径
        double mid = (l+r)/2;
        double phi = 0;
        for(int i = 0;i<n;i++) if(i!=mx) phi += acos(1-a[i]*a[i]/(2*mid*mid));
        double phii = acos(1-a[mx]*a[mx]/(2*mid*mid));
        if(flag) {
            if(phi<phii) l = mid;
            else r = mid;
        }
        else {
            if(phi+phii > 2*pi) l = mid;
            else r = mid;
        }
    }
    r = l;
    ans[0].x = 0; ans[0].y = 0;
    ans[1].x = 0,ans[1].y= a[0];
    node ve,circ;
    if(flag && mx == 0) {
   //判断多边形在圆中的位置
        ve.x = sqrt(r*r-a[0]*a[0]/4);
        ve.y = a[0]/2;
        circ.x = -ve.x; circ.y = a[0]/2;
    }
    else {
        ve.x = -sqrt(r*r-a[0]*a[0]/4);
        ve.y = a[0]/2;
        circ.x = -ve.x; circ.y = ve.y;
    }
    for(int i = 1;i<n;i++) {
        double c = acos(1-a[i]*a[i]/(2*r*r));
        if(flag && i ==mx) c = 2*pi-c;
        c = -c;
        ve = ve*c;
        ans[i+1] = circ+ve;
    }
    for(int i = 0;i<n;i++) printf("%.6f\n%.6f\n\n",ans[i].x,ans[i].y);
    return 0;
}
版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/huayunhualuo/article/details/52605651

智能推荐

攻防世界_难度8_happy_puzzle_攻防世界困难模式攻略图文-程序员宅基地

文章浏览阅读645次。这个肯定是末尾的IDAT了,因为IDAT必须要满了才会开始一下个IDAT,这个明显就是末尾的IDAT了。,对应下面的create_head()代码。,对应下面的create_tail()代码。不要考虑爆破,我已经试了一下,太多情况了。题目来源:UNCTF。_攻防世界困难模式攻略图文

达梦数据库的导出(备份)、导入_达梦数据库导入导出-程序员宅基地

文章浏览阅读2.9k次,点赞3次,收藏10次。偶尔会用到,记录、分享。1. 数据库导出1.1 切换到dmdba用户su - dmdba1.2 进入达梦数据库安装路径的bin目录,执行导库操作  导出语句:./dexp cwy_init/[email protected]:5236 file=cwy_init.dmp log=cwy_init_exp.log 注释:   cwy_init/init_123..._达梦数据库导入导出

js引入kindeditor富文本编辑器的使用_kindeditor.js-程序员宅基地

文章浏览阅读1.9k次。1. 在官网上下载KindEditor文件,可以删掉不需要要到的jsp,asp,asp.net和php文件夹。接着把文件夹放到项目文件目录下。2. 修改html文件,在页面引入js文件:<script type="text/javascript" src="./kindeditor/kindeditor-all.js"></script><script type="text/javascript" src="./kindeditor/lang/zh-CN.js"_kindeditor.js

STM32学习过程记录11——基于STM32G431CBU6硬件SPI+DMA的高效WS2812B控制方法-程序员宅基地

文章浏览阅读2.3k次,点赞6次,收藏14次。SPI的详情简介不必赘述。假设我们通过SPI发送0xAA,我们的数据线就会变为10101010,通过修改不同的内容,即可修改SPI中0和1的持续时间。比如0xF0即为前半周期为高电平,后半周期为低电平的状态。在SPI的通信模式中,CPHA配置会影响该实验,下图展示了不同采样位置的SPI时序图[1]。CPOL = 0,CPHA = 1:CLK空闲状态 = 低电平,数据在下降沿采样,并在上升沿移出CPOL = 0,CPHA = 0:CLK空闲状态 = 低电平,数据在上升沿采样,并在下降沿移出。_stm32g431cbu6

计算机网络-数据链路层_接收方收到链路层数据后,使用crc检验后,余数为0,说明链路层的传输时可靠传输-程序员宅基地

文章浏览阅读1.2k次,点赞2次,收藏8次。数据链路层习题自测问题1.数据链路(即逻辑链路)与链路(即物理链路)有何区别?“电路接通了”与”数据链路接通了”的区别何在?2.数据链路层中的链路控制包括哪些功能?试讨论数据链路层做成可靠的链路层有哪些优点和缺点。3.网络适配器的作用是什么?网络适配器工作在哪一层?4.数据链路层的三个基本问题(帧定界、透明传输和差错检测)为什么都必须加以解决?5.如果在数据链路层不进行帧定界,会发生什么问题?6.PPP协议的主要特点是什么?为什么PPP不使用帧的编号?PPP适用于什么情况?为什么PPP协议不_接收方收到链路层数据后,使用crc检验后,余数为0,说明链路层的传输时可靠传输

软件测试工程师移民加拿大_无证移民,未受过软件工程师的教育(第1部分)-程序员宅基地

文章浏览阅读587次。软件测试工程师移民加拿大 无证移民,未受过软件工程师的教育(第1部分) (Undocumented Immigrant With No Education to Software Engineer(Part 1))Before I start, I want you to please bear with me on the way I write, I have very little gen...

随便推点

Thinkpad X250 secure boot failed 启动失败问题解决_安装完系统提示secureboot failure-程序员宅基地

文章浏览阅读304次。Thinkpad X250笔记本电脑,装的是FreeBSD,进入BIOS修改虚拟化配置(其后可能是误设置了安全开机),保存退出后系统无法启动,显示:secure boot failed ,把自己惊出一身冷汗,因为这台笔记本刚好还没开始做备份.....根据错误提示,到bios里面去找相关配置,在Security里面找到了Secure Boot选项,发现果然被设置为Enabled,将其修改为Disabled ,再开机,终于正常启动了。_安装完系统提示secureboot failure

C++如何做字符串分割(5种方法)_c++ 字符串分割-程序员宅基地

文章浏览阅读10w+次,点赞93次,收藏352次。1、用strtok函数进行字符串分割原型: char *strtok(char *str, const char *delim);功能:分解字符串为一组字符串。参数说明:str为要分解的字符串,delim为分隔符字符串。返回值:从str开头开始的一个个被分割的串。当没有被分割的串时则返回NULL。其它:strtok函数线程不安全,可以使用strtok_r替代。示例://借助strtok实现split#include <string.h>#include <stdio.h&_c++ 字符串分割

2013第四届蓝桥杯 C/C++本科A组 真题答案解析_2013年第四届c a组蓝桥杯省赛真题解答-程序员宅基地

文章浏览阅读2.3k次。1 .高斯日记 大数学家高斯有个好习惯:无论如何都要记日记。他的日记有个与众不同的地方,他从不注明年月日,而是用一个整数代替,比如:4210后来人们知道,那个整数就是日期,它表示那一天是高斯出生后的第几天。这或许也是个好习惯,它时时刻刻提醒着主人:日子又过去一天,还有多少时光可以用于浪费呢?高斯出生于:1777年4月30日。在高斯发现的一个重要定理的日记_2013年第四届c a组蓝桥杯省赛真题解答

基于供需算法优化的核极限学习机(KELM)分类算法-程序员宅基地

文章浏览阅读851次,点赞17次,收藏22次。摘要:本文利用供需算法对核极限学习机(KELM)进行优化,并用于分类。

metasploitable2渗透测试_metasploitable2怎么进入-程序员宅基地

文章浏览阅读1.1k次。一、系统弱密码登录1、在kali上执行命令行telnet 192.168.26.1292、Login和password都输入msfadmin3、登录成功,进入系统4、测试如下:二、MySQL弱密码登录:1、在kali上执行mysql –h 192.168.26.129 –u root2、登录成功,进入MySQL系统3、测试效果:三、PostgreSQL弱密码登录1、在Kali上执行psql -h 192.168.26.129 –U post..._metasploitable2怎么进入

Python学习之路:从入门到精通的指南_python人工智能开发从入门到精通pdf-程序员宅基地

文章浏览阅读257次。本文将为初学者提供Python学习的详细指南,从Python的历史、基础语法和数据类型到面向对象编程、模块和库的使用。通过本文,您将能够掌握Python编程的核心概念,为今后的编程学习和实践打下坚实基础。_python人工智能开发从入门到精通pdf

推荐文章

热门文章

相关标签